Welcome!
Forum users
  • Please read this before asking for help, and don't forget to add Quick System Info to help requests!
  • Please follow the Forum Rules

Current releases
--MX-21 release info here
--Migration information to MX-21 here
--antiX-21 (Grup Yorum) release info here

Important information
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- New Forum Features, Marking Solved and Referencing a User: here

WiFi keeps dropping - power saving option?

Help for Current Versions of MX
When asking for help, use Quick System Info from MX Tools. It will be properly formatted using the following steps.
1. Click on Quick System Info in MX Tools
2. Right click in your post and paste.
Post Reply
Message
Author
wawylen
Posts: 26
Joined: Sat Dec 26, 2020 9:53 pm

WiFi keeps dropping - power saving option?

#1 Post by wawylen »

Hi!
I've been posted about this in someone else's SOLVED topic, but since my problem is not solved here we go again.
This persisted while i ran Ubuntu, too, and I thought it will disappear on MX but it didn't.
WiFi works fine for day or two and then disconnects. Sometimes it disconnects few times a day. It's hard to determine when it's solved, because when I changed Config file on the picture, it worked fine for about day and a half and then disconnected again. So I guess I'll have to be connected for a week or so to claim it's fixed.
When it disconnects, the only solution is restart.
I've tried many solutions from many forums and by symptoms and other users experiences I concluded it's due to power management bug (also because most users reported the same problem & symptoms).
I ignored this for too long but now I have to be determineg to fix it because it's really annoying and I can't believe Linux developers cannot fix this for years.

Anyway, on the picture below is my current setting I made two days ago (and not working as it seems). Are there any other settings in the power management I can apply?
Note: my laptop is constantly on AC plugin since the battery is old.

Thanks!

Code: Select all

System:    Host: <filter> Kernel: 4.19.0-13-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-4.19.0-13-amd64 
           root=UUID=<filter> ro quiet splash 
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.5 info: xfce4-panel wm: xfwm4 dm: LightDM 1.26.0 
           Distro: MX-19.3_x64 patito feo November 11  2020 base: Debian GNU/Linux 10 (buster) 
Machine:   Type: Laptop System: Acer product: Aspire 5750ZG v: V1.17 serial: <filter> Chassis: 
           type: 10 v: 1.17 serial: <filter> 
           Mobo: Acer model: JE50_HR serial: <filter> BIOS: Acer v: 1.17 date: 12/30/2011 
Battery:   ID-1: BAT0 charge: 13.0 Wh condition: 13.0/47.5 Wh (27%) volts: 12.1/10.8 
           model: SANYO Li_Ion_4000mA type: Li-ion serial: <filter> status: Full 
CPU:       Topology: Dual Core model: Intel Pentium B960 bits: 64 type: MCP arch: Sandy Bridge 
           family: 6 model-id: 2A (42) stepping: 7 micriocode: 2F L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 8780 
           Speed: 1165 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 1440 2: 1446 
           Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
           STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
           vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0106 
           Device-2: NVIDIA GF108M [GeForce 610M] vendor: Acer Incorporated ALI driver: N/A 
           bus ID: 01:00.0 chip ID: 10de:0dea 
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 18.3.6 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
           vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:1c20 
           Device-2: NVIDIA GF108 High Definition Audio vendor: Acer Incorporated ALI 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0bea 
           Sound Server: ALSA v: k4.19.0-13-amd64 
Network:   Device-1: Broadcom Limited NetLink BCM57785 Gigabit Ethernet PCIe 
           vendor: Acer Incorporated ALI driver: tg3 v: 3.137 port: 2000 bus ID: 02:00.0 
           chip ID: 14e4:16b5 
           IF: eth0 state: down mac: <filter> 
           Device-2: Broadcom Limited BCM43227 802.11b/g/n vendor: Foxconn driver: wl v: kernel 
           port: 2000 bus ID: 03:00.0 chip ID: 14e4:4358 
           IF: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 26.20 GiB (5.6%) 
           ID-1: /dev/sda vendor: Western Digital model: WD5000LPLX-00ZNTT0 size: 465.76 GiB 
           block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: 1A01 scheme: MBR 
Partition: ID-1: / raw size: 465.76 GiB size: 457.45 GiB (98.22%) used: 26.20 GiB (5.7%) 
           fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 79.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://deb.debian.org/debian buster-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://deb.debian.org/debian buster main contrib non-free
           2: deb http://deb.debian.org/debian-security buster/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb https://ftp.arnes.si/mirrors/mxlinux/packages/mx/repo/ buster main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:      Processes: 184 Uptime: 12m Memory: 3.71 GiB used: 1012.0 MiB (26.6%) Init: SysVinit 
           v: 2.93 runlevel: 5 default: 5 Compilers: gcc: 8.3.0 alt: 8 Shell: quick-system-in 
           running in: quick-system-in inxi: 3.0.36 


etc/laptop-mode/conf.d/wirelesspower.conf
Image

User avatar
Huckleberry Finn
Qualified MX Guide
Posts: 9791
Joined: Sat Jun 22, 2019 8:35 am

Re: WiFi keeps dropping - power saving option?

#2 Post by Huckleberry Finn »

Though it's always on AC, have you tried disabling (and even removing) tlp ?

/etc/default/tlp

TLP_ENABLE=1 to 0

(But first to see which one works and to prevent conflicts, rename your own file to xxx.conf.old )

Try a few boots..

After trying that, you can also enable it again (to =1 ) and just play with the related lines, say, make both "off":

By default (about line 166):

# WiFi power saving mode: on=enable, off=disable; not supported by all adapters.
WIFI_PWR_ON_AC=off
WIFI_PWR_ON_BAT=on
________________________________________

Or you can install tlpui ( a GUI for tlp ) from MX Package Installer Test Repo.
________________________________________

Yes, there are power saving options for some drivers but till now I haven't heard one for wl. ( you can issue the command modinfo wl to see them ).

If you don't mind: you can also reset Bios to factory defaults (since it's going on no matter what distro it is) . Generally on Exit menu: "Load Setup Defaults" "save&exit" .

( And, of course there might also be a tiny issue inside the case, something loose .. hardware related ... )
_______________________________________

P.S. Also Bluetooth (wireless) devices may be causing that. Both use 2.4Ghz and conflict. At least you can uncheck Bluetooth from Session and Startup , (also try without wireless devices, mouse, keyboard etc..)

When asking for help, please first:
Menu => MX Tools => Quick System Info

The output is copied into the clipboard
including code tags for the forum.

wawylen
Posts: 26
Joined: Sat Dec 26, 2020 9:53 pm

Re: WiFi keeps dropping - power saving option?

#3 Post by wawylen »

OK, will try with tlpui, thanks.
And I'll see the results.

User avatar
JayM
Qualified MX Guide
Posts: 10668
Joined: Tue Jan 08, 2019 4:47 am

Re: WiFi keeps dropping - power saving option?

#4 Post by JayM »

Several ideas in no particular order of priority or importance:

If it's happening across different distros it could be kernel-related (depending on what kernel you had in Ubuntu) or firmware-related.

Run MX Package Installer, Popular Applications tab, Kernels category and install the antiX 4.9 kernel then run MX Boot Options and select the antiX kernel as the default, click Apply then reboot. The older kernel may give better support for your older hardware including your wifi card.

Check Acer's support website for a BIOS upgrade for your laptop. There's a version 1.21 from 2012 available that may fix the wifi issue. Follow Acer's instructions for flashing your BIOS. (It's a good idea to reset your BIOS to defaults prior to flashing it witth another version.)

It could also be hardware-related, i.e. a bad wifi card. They're user-replaceable so you could get a different one of the same size, disconnect the antennas and swap the card if that's what turns out to be the problem.

Another thought: many routers offer a combination of different wifi protocols and it could be that your card has a hard time negotiating the proper protocol with your router. You could try setting your router to use just one protoccol that's compatible with your card such as 802.11n.

Lastly, if you suspect a power-saving issue and as you're always using the laptop on AC power try setting its power control setting from auto to none.
Please read the Forum Rules, How To Ask For Help, How to Break Your System and Don't Break Debian. Always include your full Quick System Info (QSI) with each and every new help request.

Post Reply

Return to “MX Help”